10 Ocak 2009 Cumartesi

App Store'da Not Compatible Mesajı

Bu aralar kullanıcıların bazıları, App Store'dan Facebook uygulamasını yüklemeye çalıştıklarında aşağıdaki ekran görüntüsünde olduğu gibi "This application is not compatible with this iPhone" mesajı ile karşılaşıyorlar.



Bu hata mesajının çıkmasının sebebi Facebook uygulamasının, en az iPhone 2.2 versiyonu ile çalışır şekilde geliştirilmesidir. Hali hazırda bir çok iPhone sahibi halen 2.0 veya 2.1 versiyonunda kaldığı için Facebook uygulamasında olduğu gibi 2.2 veya üstü versiyonu isteyen uygulamaları yükleyememektedirler. 2.2.1 versiyonu çıkalı epey olduğu için, yeni geliştirilen veya güncellenen uygulamaların eski versiyonları desteklememe ihtimali her geçen gün artmaktadır.

GÜNCELLEME (20/06/2009) : Bu yazı ilk yayınlandığında en güncel versiyon 2.2.1 idi. Şu an ise 3.0. Dolayısıyla henüz 3.0'a geçmediyseniz bundan sonra yukarıdaki hata mesajı ile bol bol karşılaşma olasılığınız var. Zaten uygulamaların iTunes'taki açıklama (description) kısımlarında aşağıdaki gibi "Requires iPhone OS 3.0 or later" yani "iPhone 3.0 veya daha sonrası bir yazılım gerektirir" ifadesini görürsünüz.

Dolayısıyla bu mesajla karşılaşmamak için kullanıcıların cihazlarını, iTunes'taki "Update" (Güncelle) seçeneğini kullanarak en üst versiyona yükseltmeleri gerekmektedir. Şu an için en güncel versiyon 3.0'dır.



Apple'ın yayınladığı en güncel versiyonu kullandığınız sürece yukarıdaki gibi bir mesaj almanıza imkan yoktur.

ÖNEMLİ UYARI : Türkiye'den (Turkcell, Vodafone, Teknosa, vs.) orijinal iPhone 3G alan kullanıcılar, 3.0 update işlemini korkmadan yapabilirler. Fakat yurt dışından getirenler, update yaptıktan sonra unlock veya jailbreak işlemi yapmak zorunda kalabilir. Dolayısıyla cihazınızı yurt dışından aldıysanız/aldırttıysanız ve jailbreak, unlock konularında tecrübeli değilseniz bu konuda tecrübeli kişilere danışmadan 3.0 update YAPMAYIN.

7 comments:

iPhone Fun Club dedi ki...

Arkadaşlar güzel ve faydalı bir site olmuş, ellerinize sağlık.
Bir de size ulaşılabilecek bir e-posta adresi ekleyebilirseniz çok sevinirim.

Mustafa Tan dedi ki...

Teşekkürler.

mustafatan75@gmail.com adresinden iletişime geçebilirsiniz.

yaman dedi ki...

slmlar.. dun ilk defa itunes'a tlfnumdan baglanmak istedim. ama uzgunuz bu ulkede calişmiyor şeklinde bir yazı ile karşilaştim.(cannot connect to the itunes store.the itunes store is not supported in this country). nedir ne yapmak gerekir?? bilgisayarimdan ise rahatlikla erişip apple sptore yada itunes ile herşeyi yapabiliyorum.hattım vodafon(alakasi var ise). teşekkurler

Mustafa Tan dedi ki...

Selamlar Yaman Bey,

Yaşadığınız sorunun sebebi ile ilgili bir yazı paylaştım.

Bilginize

Özge dedi ki...

Ama benim sürümüm 2.2 olmasına rağmen aynı hatayla karşılaşıorum ve yükleme yapamıorum bu konuda yardımcı olabilir misiniz...

Mustafa Tan dedi ki...

Selamlar Özge Hanım,

Eğer cihazınız 2.2 iken bu hatayı alıyorsanız o zaman indirmeye çalıştığınız uygulama 2.2.1 versiyonunu istiyordur. İndirmeye çalıştığını uygulama hangisidir ?

Özge dedi ki...

Sürümüm 2.2.1 indirmek istediğim de facebook uygulaması...

t